Thursday, January 11, 2007

RepCA on HPUX 64-Bit

You may run into the following errors when running RepCA on HPUX 64-Bit (Itanium):

in the repca.log file

[CustomExternalProcessAction] Command line: /oracle/product/10.1.2.mrca/jdk/bin/java -cp /oracle/product/10.1.2.mrca/assistants/opca/jlib/opca.jar:/oracle/product/10.1.2.mrca/portal/jlib/ptlshare.jar:/oracle/product/10.1.2.mrca/jdbc/lib/classes12.jar:/oracle/product/10.1.2.mrca/jdbc/lib/nls_charset12.jar oracle.webdb.config.PortalConfigAssistant
[CustomExternalProcessAction] Process exited abnormally
[CustomExternalProcessAction] Action failed due to: oracle.ias.repca.ifs.utils.action.ActionFailedException: Some of the operations have failed during this OracleAS RepCA session. Please see the log file at /oracle/product/10.1.2.mrca/assistants/repca/log/repca_2007-01-11_01-38-25_PM.log for further details.
ERROR - Some of the operations have failed during this OracleAS RepCA session. Please see the log file at /oracle/product/10.1.2.mrca/assistants/repca/log/repca_2007-01-11_01-38-25_PM.log for further details.
oracle.ias.repca.ifs.utils.action.ActionFailedException: Some of the operations have failed during this OracleAS RepCA session. Please see the log file at /oracle/product/10.1.2.mrca/assistants/repca/log/repca_2007-01-11_01-38-25_PM.log for further details.
at oracle.ias.repca.actions.CustomExternalProcessAction.perform(CustomExternalProcessAction.java:155)
at oracle.ias.repca.ifs.utils.action.ActionQueue.performActions(ActionQueue.java:319)
at oracle.ias.repca.ifs.utils.action.ActionQueue.run(ActionQueue.java:245)
at java.lang.Thread.run(Thread.java:534)



in the sso.log file

...end of SSO install

INSTALL_ACTION:createSSOSchema() : loadjava -resolve -verbose -user orasso/orasso@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=xxxxx))) /oracle/product/10.1.2.mrca/portal/admin/plsql/sso/SSOExtDB.class

arguments: '-resolve' '-verbose' '-user' 'orasso/orasso@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=xxxxx)))' '/oracle/product/10.1.2.mrca/portal/admin/plsql/sso/SSOExtDB.class'

SQL Error while connecting with oci8 driver to (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=xxxxx))): Closed Connection

exiting : could not open connection

INSTALL_ACTION:createSSOSchema() : loadjava -resolve -verbose -user orasso/orasso@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=xxxxx))) /oracle/product/10.1.2.mrca/portal/admin/plsql/wwc/SSOHash.class

arguments: '-resolve' '-verbose' '-user' 'orasso/orasso@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=xxxxx)))' '/oracle/product/10.1.2.mrca/portal/admin/plsql/wwc/SSOHash.class'

SQL Error while connecting with oci8 driver to (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=xxxxx))): Closed Connection

exiting : could not open connection

INSTALL_ACTION : Set the component loading flag for SSO

ERROR: Setting the component loading flag in the DBMS registry raised exception.



It could be that the loadjava of the repca doesn't work well in this configuration. There are probably at least two issues: first, the symbolic link $REPCA_HOME/JRE does not point to the correct location. It needs to point to the full JRE location (java/1.3.1). Second, the loadjava itself is an issue. I tried to solve the problem in a bunch of ways, but found the easiest thing to do is just run the repca from a Windows or Linux box. Much faster than troubleshooting the install on HPUX.